[Win32Service] Support de PHP 7.0 et PHP 7.1

Comme pour tout projet libre et populaire, il est nécessaire de mettre en place une gestion des versions supportées.

Les versions supportées sont les versions dont l’éditeur ou la communauté chargés du projet propose des mises à jour pour corriger des dysfonctionnements (bugs) ou des vulnérabilités (failles de sécurité).

Pour le projet PHP, c’est le cas et vous pouvez en voir une représentation graphique et tabulaire sur la page dédiée.

Quel est le rapport avec Win32Service ? Le rapport est très simple, l’extension utilise le service en ligne AppVeyor pour construire et tester automatique l’extension pour toutes les modifications réalisées sur le projet. Il permet également le téléchargement des DLL pour les utiliser sur vos environnements et ainsi me fournir des retours d’expérience.

Pour que la construction de l’extension soit réalisée à chaque modification il est nécessaire de récupérer les outils nécessaires pour la compilation de PHP. Ces outils sont gérés par la communauté en charge du projet PHP. Ce fait ne me permet de construire l’extension que pour les versions de PHP actuellement supportées ayant les outils de construction disponible.

Cependant, vous avez toujours la possibilité de télécharger les anciennes versions de l’extension via le site pecl.php.net ou via le projet sur GitHub.

Si vous souhaitez disposer de la dernière version de l’extension sur une version de PHP 7 non supportée, vous avez la possibilité de réaliser vous-même la construction de l’extension.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.